Elementor - szétesett oszlopos nézet


#1

Sziasztok! A hajnali órákban a 3 oszlopos elrendezésű elementoros multisite weboldalam egyik aloldala a front oldalon szétesett (a szerkesztőben semmi észlelhető hibát nem találtam) A forráskódban a csatolt képen látható <“em”><“b”><“strong”> tagek miatt esik szét, azonban sehol sem találom őket a fájlokban. Történt már valakivel ilyesmi? Van valami tanácsotok?

Előre is köszi!

em-hiba


#2

Kedves Dávid!

Ha megkérdezted, van tanácsom.

WordPress-hez készült page-builder-ek minőségét vizsgálgattam, jelentkeztem is állásra itt-ott. Az eredmény az lett, hogy a Beaver Builder magasan a legfenntarthatóbb.

A többiek szakértelemről nem tesznek bizonyságot.


#3

Hát azért ezt megkérdőjelezném. Amikor a WordPress egyik verziójában (ha jól emlékszem, akkor a 4.0-ban) bekerültek a felújított core widgeteket, mint a Text vagy az Image, ami elég sok JS-t használ az init-hez, akkor a Breaver Builder nem tudta megcsinálni, hogy ezek működjenek a bővítményükbe. Ha jól látom, akkor ezek még most sem működnek náluk.

Mondjuk az Elementor-nak is sok furcsasága van, nagyon sok minden túl van bonyolítva. Ugyanakkor a WordPress kompatibilitása elég jónak mondható. A saját widget rendszerük pedig szépen felépített, könnyű bővíteni. Hiányosságok persze vannak, mondjuk repeater-be nem lehet repeater field.

Visual Composer kódminősége pedig a legrosszabb, ott alapvető PHP standard hibák is vannak, amit egy kezdő fejlesztőnek is látnia kellene, a WordPress standard-hez meg szerintem semmi köze a bővítménynek.

Azt azért figyelembe kell venni, hogy a verzió kompatibilitás miatt nem írhatják újra a teljes kódot, még akkor sem, ha képesek lennének sokkal jobbat írni.


#4

Nehéz lenne megmondani, hogy mi okoz ilyen hibát.

Lehet a page builderbe esett szét valami, ilyenkor azt tanácsolnám, hogy készíts egy teljesen új oldalt, és rakd össze újra.

De az is lehet, hogy valami másik bővítmény zavar be a működésbe. Ezt úgy tudod kipróbálni, hogy kikapcsolod az összes bővítményt (kivéve persze az Elementor-t), és megnézed, hogy megmarad a hiba, vagy megszűnik. Ha megszűnik, akkor tényleg valamelyik bővítmény lesz a probléma forrása, egyesével kapcsolgasd be az összeset, és teszteld, amelyik bekapcsolása után újra jelentkezik a hiba, az lesz a problémás.