PHP verzió váltás után nem jelenik meg megfelelően az oldal


#1

Sziasztok!

A következőben kérném a segítségeteket, egy oldal szolgáltatójánál a rég átállított PHP 5.3-ról 7.3ra, vagy akár 7.2-re állítás után ugyan megjelenik az oldal, és a wp kezelő felület is, de a következő PHP hiba üzenetek jelennek meg az oldal felett, valamint a kezelőfelület fejléce helyén:

Pontosan, hogy mit kéne tennem az oldal működése érdekében, hogy új, aktuális PHP verzióval futhasson az oldal?

Az oldalon Avada sablonban van, és a mediacenteren van a tárhely, amennyiben ez az információ segítség.

Előre is köszönök bármilyen segítséget!


#2

Szia!
Mindened a legfrissebb? Avada sablon, bővítmények, Wordpress keretrendszer?

Esetleg ezt olvastad, próbáltad? Vagy még ezt találtam .


#3

Nem a cannot modify header hibaüzenetet kell eltüntetni, hanem a kiváltó okát. Jelen esetben feltételezem, hogy a wp-config.php-ben hibásan van a konstans definíció írva. Pl valahogy így:

define(ENABLE_CACHE, true);

De itt idézőjelben kellene lenni, mivel itt jön létre. Így:

define('ENABLE_CACHE', true);

Egyébként régen is volt “NOTICE” szintű hibaüzenet a hibás konstans használatra, de azt éles szerveren el szokták nyomni, mert sok szokott lenni. Most viszont már WARNING lett belőle és megjelent.


#4

Ha évekre előre szeretnél minden hibát megelőzni, keress fel.

és együtt szánkázunk ezen a dombon